Browser capabilities

The Melbourne Cup Carnival website is designed to work with most web browsers:

  • Microsoft Internet Explorer 8 and above
  • Mozilla Firefox 3.5 and above
  • Apple Safari 4 and above
  • Google Chrome 10 and above.

We recommend you always use the current version of browsers to make sure our web pages display quickly, and that you have the latest security updates.

If you use older browsers (Apple Safari 3) or less standard compliant browsers (Microsoft Internet Explorer 7), you might notice some subtle differences that some functions and features may have display issues as we make upgrades to the Melbourne Cup Carnival site.

When the website is compared side by side with older browsers such as Apple Safari 3 or Microsoft Internet Explorer 7, there are likely to be subtle differences. These however will not impact your usability of the website.